This is an error that I have recieved numerous times in the past two weeks. It is reported to the .Net Framework as "Login Failed for user DOMAIN\USER" .
Date 27/05/2012 15:37:05
Log SQL Server (Current - 30/05/2012 11:15:00)
Source Logon
Message
Login failed for user 'DOMAIN\USER'. Reason: Token-based server access validation failed with an infrastructure error. Check for previous errors. [CLIENT: 192.168.0.0]
With the previous error being, something similar to:
Date 27/05/2012 15:37:05
Log SQL Server (Current - 30/05/2012 11:15:00)
Source Logon
Message
Error: 18456, Severity: 14, State: 11.
It seems this error message can have the following causes:
NB: This is not an exhustive list.
- The web suggest that UAC can cause this error. Try running the application as an administrator and see if that fixes your issue.
- Another cause can be when a domain user is deleted from AD and removed at the server level then re-created at in AD and SQL SERVER. This causes a mis-match in the SID's at the database level and throws the above error. Delete the user and re-add at the database level to solve this.
- User is logging in as a local user that has the same name and password as a domain user. Classic example: Administrator accounts.
If you know of any causes or resources that are associated with this error, leave me a comment and i'll add it to the post.
Hope this helps someone.
Share Via Twitter